Como verificar se uma célula está vazia no Excel?

Escrito por kate bluest | Traduzido por lilian silva
  • Compartilhar
  • Tweetar
  • Compartilhar
  • Pin
  • E-mail
Como verificar se uma célula está vazia no Excel?
Apenas com algumas teclas, usando a função correta no Excel, você economiza horas de trabalho (Manos en teclado 40409 image by pablo from Fotolia.com)

Em planilhas grandes e complexas, localizar células vazias requer mais do que uma simples verificação. Existem vários métodos disponíveis para fazer a tarefa de identificá-las. Alguns exemplos são as funções ISBLANK, LEN e IF.

A função ISBLANK retorna o valor lógico VERDADEIRO se a célula estiver vazia. A função LEN retorna um valor que informa o número de caracteres em uma sequência ou o número de bytes necessários para armazenar uma variável em uma célula. Se uma célula estiver em branco, o valor será zero segundo a Microsoft. Você pode usar a função SE com aspas vazias ("") para testar células vazias.

Para esclarecer a utilização das funções: "B2" representa a célula a ser testada. "E2" representa a célula que receberá a fórmula. Use os valores de seus dados no lugar desses endereços de células. Para simplificar sua fórmula, observe que: se os cabeçalhos estão em uma fileira, os números das linhas devem ser iguais; se os cabeçalhos estão em uma coluna, as letras das colunas devem ser iguais.

Nível de dificuldade:
Moderado

Outras pessoas estão lendo

Instruções

    Função ISBLANK

  1. 1

    Abra a planilha do Excel que será verificada.

  2. 2

    Insira um cabeçalho apropriado na primeira coluna vazia.

  3. 3

    Insira "= ISBLANK (B2)" na linha correspondente ao primeiro dado que você deseja verificar e pressione "Enter". Esta fórmula diz: "Célula B2 está vazia." Se essa afirmação é verdadeira, o valor "Verdade" aparecerá, caso contrário o valor "falso" será exibido.

  4. 4

    Copie a célula que contém a fórmula. Selecione todas as células correspondentes aos dados que devem ser verificados. Cole a fórmula.

  5. 5

    Selecione a guia "Dados" no menu e pressione "Filtrar".

  6. 6

    Clique na seta do filtro na parte superior da coluna que contém a fórmula. Selecione "verdadeiro" para ver as linhas ou colunas com células vazias.

    Função LEN

  1. 1

    Abra a planilha do Excel que será verificada.

  2. 2

    Insira um cabeçalho apropriado na primeira coluna vazia.

  3. 3

    Insira na linha correspondente aos primeiros dados que deverão ser verificados: = if (LEN (B2) < 1, "VAZIO", "NÃO ESTÁ VAZIO")

    Pressione "Enter".

    Esta fórmula diz:

    Se o valor de LEN é inferior a 1 (0), então a entrada será "VAZIO", se o valor de LEN não for inferior a 1 (0), então a entrada será "NÃO ESTÁ VAZIO."

  4. 4

    Copie a célula que contém a fórmula. Selecione todas as células correspondentes aos dados que devem ser verificados. Cole a fórmula.

  5. 5

    Selecione a guia "Dados" no menu e pressione "Filtrar".

  6. 6

    Clique na seta do filtro na parte superior da coluna que contém a fórmula. Selecione "VAZIO" para ver as linhas ou colunas com células vazias.

    Função IF

  1. 1

    Abra a planilha do Excel que será verificada.

  2. 2

    Insira um cabeçalho apropriado na primeira coluna vazia.

  3. 3

    Insira na linha correspondente aos primeiros dados que deverão ser verificados:

    = SE(B2 = "", "VAZIO", "NÃO ESTÁ VAZIO")

    Pressione "Enter".

  4. 4

    Copie a célula que contém a fórmula. Selecione todas as células correspondentes aos dados que devem ser verificados. Cole a fórmula.

  5. 5

    Selecione a guia "Dados" no menu e pressione "Filtrar".

  6. 6

    Clique na seta do filtro na parte superior da coluna que contém a fórmula. Selecione "VAZIO" para ver as linhas ou colunas com células vazias.

Dicas & Advertências

  • Teste para ver que uma célula vazia não é o mesmo que uma célula com o valor zero. Se uma célula tem um valor zero, ela não está vazia. Para testar valores "zero", use "= SE(B2 ="0",0,1)". Essa fórmula diz que se a célula B2 é igual a zero, escreva 0, caso contrário escreva 1.

Não perca

Filtro:
  • Geral
  • Artigos
  • Slides
  • Vídeos
Mostrar:
  • Mais relevantes
  • Mais lidos
  • Mais recentes

Nenhum artigo disponível

Nenhum slide disponível

Nenhum vídeo disponível