Como contar quantas vezes uma palavra aparece no Excel

Escrito por shawn mcclain | Traduzido por a. araújo
  • Compartilhar
  • Tweetar
  • Compartilhar
  • E-mail

O Microsoft Excel 2010 contém uma variedade de funções que podem ser manipuladas para analisar seus dados. Se for necessário contar quantas células combinam com uma certa condição, a função CONT.SE fará o trabalho. Essa função, entretanto, só contará cada célula uma vez, o que significa que se a palavra aparece mais de uma vez em uma única célula, será necessário dividir o texto em várias células individuais para obter uma contagem adequada.

Nível de dificuldade:
Moderadamente fácil

Outras pessoas estão lendo

Instruções

  1. 1

    Abra o documento do Excel que contém o texto que deseja analisar. Selecione a primeira célula que contém o texto, segure a tecla "Shift" e selecione a última célula que contém seu texto: isso criará uma caixa de seleção ao redor de todo o texto. Pressione "Ctrl + C" para copiar a informação para a área de transferência.

  2. 2

    Clique em uma nova planilha na parte inferior da tela. Caso todas elas estejam sendo usadas, pressione o botão à direita da última planilha para criar uma nova.

  3. 3

    Selecione a célula "B1" na nova planilha. Pressione "Ctrl + V" para colar a informação. Clique na letra "B" sobre a informação colada para selecionar toda a coluna.

  4. 4

    Clique na aba "Dados" e então selecione o botão "Texto para colunas": isso abrirá uma pequena janela. Escolha "Delimitado" na primeira página e clique em "Avançar". Clique em "Espaço" nas opções fornecidas e depois em "Concluir". Cada palavra do texto deverá agora ter sua própria célula.

  5. 5

    Selecione a célula "A1". Digite a seguinte fórmula: =CONT.SE(B:Z, "x"), onde "Z" é a última coluna contendo texto e "x" é a palavra procurada. Pressione enter e o número de vezes que essa palavra aparece no texto será mostrado na célula "A1". Selecione a célula "A2" e digite a seguinte fórmula: =CONT.SE(B:Z, "x?") para contar ocorrências em que a palavra é seguida por sinais de pontuação.

  6. 6

    Selecione a célula "A3" e digite a seguinte fórmula: =SOMA(A1,A2) para obter a contagem final de quantas vezes a palavra aparece no texto.

Dicas & Advertências

  • Caso seu texto já esteja espaçado de forma que apenas uma palavra esteja em cada célula, você pode pular os passos de copiar o texto para uma nova planilha e rodar a janela de "Texto para colunas".

Não perca

Filtro:
  • Geral
  • Artigos
  • Slides
  • Vídeos
Mostrar:
  • Mais relevantes
  • Mais lidos
  • Mais recentes

Nenhum artigo disponível

Nenhum slide disponível

Nenhum vídeo disponível