Como usar múltiplas funções lógicas no MS Excel

Escrito por shreya mehta | Traduzido por bruna biagioli
  • Compartilhar
  • Tweetar
  • Compartilhar
  • Pin
  • E-mail
Como usar múltiplas funções lógicas no MS Excel
Funções são úteis ao se testar valores em células para determinar se satisfazem a determinadas condições (Stockbyte/Stockbyte/Getty Images)

Funções lógicas no Microsoft Excel consistem em: SE, OU, E, VERDADEIRO, FALSO e NAO. Essas funções são úteis ao se testar valores em células para determinar se satisfazem a determinadas condições e, dentre a maioria das funções lógicas normalmente usadas, está a função SE. Quando várias condições precisam ser testadas, pode-se usar funções aninhadas.

Nível de dificuldade:
Moderado

Outras pessoas estão lendo

Instruções

  1. 1

    Faça uma lista de todas as condições a serem testadas na ordem correta. Por exemplo, em um cenário onde um cliente que paga R$ 100 ou mais recebe um desconto de 20 por cento se for um membro de sua loja, mas apenas 10 por cento se não for um membro, as condições a se testar são se o cliente gastou R$ 100 ou mais e se ele é um membro da loja.

  2. 2

    Decida de quais dentre as seis funções você necessitará. Veja o link na seção Recursos para uma descrição de cada função e qual o retorno dado por ela. Em nosso exemplo, nós precisamos usar a função SE para realizar o teste lógico. A função E será aninhada na função SE para testar se o cliente gastou ao menos R$ 100 e se ele é um membro da loja. A função OU determinará se o cliente atendeu a uma das condições a fim de qualificar o seu desconto.

  3. 3

    A estrutura da fórmula inicia com a instrução SE e o aninhamento de outras funções. No exemplo acima, configure a planilha da seguinte forma: digite 20 por cento na célula B1 para desconto para membros, 10 por cento na célula B2 para desconto para não-membros e R$ 100 para a compra mínima na célula B3. Liste os nomes dos clientes começando na célula A6, a soma da compra de cada cliente na B6 e status de membro ("Sim" ou "Não") na C6.

  4. 4

    Digite a seguinte fórmula na célula D6: =SE((E(C6="Sim",B6>=$B$3)),B6$B1$,SE((OU(B6>=$B$3)),B6$B$2,"Sem desconto"))) Essa função E testa se o cliente é um membro e se ele chegou a gastar pelo menos R$ 100. Se ambas as condições forem verdadeiras, multiplique o valor da compra por 20 por cento para determinar o valor do desconto. A função OU testa se o cliente gastou pelo menos R$ 100, mesmo não sendo um membro. Se ele atende a esta condição, multiplique o total da compra por 10 por cento. Se nenhuma das condições for verdadeira, a célula exibirá "Sem desconto".

Dicas & Advertências

  • Tenha a certeza de que os parênteses abertos foram fechados.

Não perca

Filtro:
  • Geral
  • Artigos
  • Slides
  • Vídeos
Mostrar:
  • Mais relevantes
  • Mais lidos
  • Mais recentes

Nenhum artigo disponível

Nenhum slide disponível

Nenhum vídeo disponível